dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / lxde-base / lxlauncher / lxlauncher-0.2.5-r1.ebuild
blob46a171cfdb5f5e9a573258f8c2dc96075142d5d3
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="Open source clone of the Asus launcher for EeePC"
7 HOMEPAGE="https://wiki.lxde.org/en/LXLauncher"
8 SRC_URI="https://downloads.sourceforge.net/lxde/${P}.tar.xz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
13 IUSE=""
15 RDEPEND="
16         dev-libs/glib:2
17         gnome-base/gnome-menus
18         lxde-base/menu-cache
19         x11-libs/cairo
20         x11-libs/gdk-pixbuf:2
21         x11-libs/gtk+:3
22         x11-libs/libX11
23         x11-libs/startup-notification
25 DEPEND="${RDEPEND}"
26 BDEPEND="
27         dev-util/intltool
28         sys-devel/gettext
29         virtual/pkgconfig
32 src_configure() {
33         econf \
34                 --enable-gtk3
37 src_install() {
38         emake DESTDIR="${D}" install
39         dodoc AUTHORS ChangeLog README