dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / net-mail / automx2 / automx2-2024.2.ebuild
blob671f397d3e837f27bc45f1d5fb5dff07ff27aca8
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{11,12} )
9 inherit distutils-r1
11 DESCRIPTION="Email client autoconfiguration service"
12 HOMEPAGE="https://rseichter.github.io/automx2/"
13 SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
15 LICENSE="GPL-3+"
16 SLOT="0"
17 KEYWORDS="amd64"
19 RDEPEND="acct-user/automx2
20         dev-python/flask[${PYTHON_USEDEP}]
21         dev-python/flask-migrate[${PYTHON_USEDEP}]
22         dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
23         dev-python/ldap3[${PYTHON_USEDEP}]
26 PATCHES=(
27         "${FILESDIR}/${P}-setupcfg.patch"
30 distutils_enable_tests unittest
32 python_test() {
33         local -x AUTOMX2_CONF="tests/unittest.conf"
34         eunittest tests/
37 python_install_all() {
38         local DOCS=( "${S}"/docs/*.adoc "${S}"/contrib/*sample.conf )
39         local HTML_DOCS=( "${S}"/docs/*.{html,svg} )
40         newconfd "${FILESDIR}/confd" "${PN}"
41         newinitd "${FILESDIR}/init-r1" "${PN}"
42         insinto /etc
43         newins "${FILESDIR}/conf" "${PN}.conf"
44         distutils-r1_python_install_all