dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / net-mail / pop-before-smtp / pop-before-smtp-1.42.ebuild
blobe294c280120aa9d70650145e7a6c97e9f195fba2
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="Simple daemon to control email relay based on successful POP or IMAP logins"
7 HOMEPAGE="http://popbsmtp.sourceforge.net"
8 SRC_URI="https://downloads.sourceforge.net/popbsmtp/${P}.tar.gz"
10 LICENSE="|| ( GPL-2 BSD Artistic )"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
14 RDEPEND="dev-lang/perl[berkdb]
15         dev-perl/Net-Netmask
16         dev-perl/TimeDate"
18 src_prepare() {
19         default
21         # enable syslog
22         sed -i \
23                 -e "/^=cut #============================= syslog ===========================START=$/d" \
24                 -e "/^=cut #============================= syslog =============================END=$/d" \
25                 "${S}"/pop-before-smtp-conf.pl \
26         || die "sed pop-before-smtp-conf.pl failed"
29 src_install() {
30         dosbin pop-before-smtp
31         dodoc README ChangeLog TODO contrib/README.QUICKSTART
32         insinto /etc
33         doins pop-before-smtp-conf.pl
34         newinitd "${FILESDIR}/pop-before-smtp.init" pop-before.smtp