dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / net-mail / vqadmin / vqadmin-2.3.7-r1.ebuild
blob1daba675423b390eaea234ef2bf7e41e464922a5
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit webapp qmail
8 DESCRIPTION="A web based control pannel to manage Virtual Qmail Domains"
9 HOMEPAGE="http://www.inter7.com/index.php?page=vqadmin"
10 SRC_URI="http://www.inter7.com/vqadmin/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 WEBAPP_MANUAL_SLOT="yes"
15 KEYWORDS="~amd64 ~sparc ~x86"
16 IUSE=""
18 DEPEND="virtual/libcrypt:=
19         virtual/qmail
20         >=net-mail/vpopmail-5.3"
21 RDEPEND="${DEPEND}
22         net-mail/qmailadmin"
24 src_prepare() {
25         default
27         # fixes for sane webapp integration
28         sed -i \
29                 -e "s|html/|/usr/share/${PN}/|g" \
30                 -e "s|/images/vqadmin/|/vqadmin/|g" \
31                 -e "s|/cgi-bin/vqadmin/|/cgi-bin/|g" \
32                 -e "s|vqadmin\.cgi|vqadmin|g" \
33                 *.h *.c html/*.html || die
36 src_configure() {
37         econf \
38                 --enable-qmaildir="${QMAIL_HOME}" \
39                 --enable-vpopuser=vpopmail \
40                 --enable-vpopgroup=vpopmail \
41                 --enable-cgibindir="${MY_CGIBINDIR}"
44 src_install() {
45         webapp_src_preinst
47         insinto /usr/share/${PN}
48         doins html/*
50         insinto "${MY_HTDOCSDIR}"
51         doins html/*.css
53         insinto "${MY_CGIBINDIR}"
54         doins vqadmin.acl
55         insopts -m 755
56         doins vqadmin
58         dodoc ACL AUTHORS BUGS ChangeLog FAQ INSTALL NEWS TODO README
60         webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
61         webapp_src_install