1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit flag-o-matic toolchain-funcs
10 DESCRIPTION="CELL spu ps and top alike utilities"
11 HOMEPAGE="https://sourceforge.net/projects/libspe"
12 SRC_URI="https://downloads.sourceforge.net/libspe/${MY_P}.tar.gz"
13 S="${WORKDIR}/${PN}/src"
29 "${FILESDIR}"/${P}-buildsystem.patch
30 "${FILESDIR}"/${P}-format-security.patch
35 append-cppflags -std=gnu89
36 export CFLAGS="${CFLAGS}"
37 export LDFLAGS="${LDFLAGS}"
38 export LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"