1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit java-utils-2 systemd tmpfiles
11 DESCRIPTION="An autosuspend and wakeup daemon"
12 HOMEPAGE="https://gitlab.com/flow/sandmann"
13 SRC_URI="https://geekplace.eu/projects/${MY_PN}/archive/${MY_P}.tar.xz"
15 S="${WORKDIR}/${MY_P}"
16 LICENSE="GPL-3+ LGPL-3"
21 # >=java-config-2.3.2 to get the libdir fix.
24 >=dev-java/java-config-2.3.2
33 -e 's|^ExecStart=.*|ExecStart=/usr/bin/sandmann|' \
34 sandmann.service || die
44 SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
46 SOURCELESS_INSTALL=true
49 emake ${my_emake_args[@]} install
51 java-pkg_newjar out/main/assembly.dest/out.jar sandmann.jar
52 java-pkg_dolauncher sandmann
58 tmpfiles_process sandmann.conf