dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / x11-misc / bbcd / bbcd-0.3.1-r5.ebuild
blob250968d07f39ea1f39c24c73789819a913ed9f01
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools flag-o-matic
8 DESCRIPTION="Basic CD Player for blackbox wm"
9 HOMEPAGE="http://tranber1.free.fr/bbcd.html"
10 SRC_URI="http://tranber1.free.fr/${P}.tar.gz"
11 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15 IUSE=""
17 RDEPEND=">=media-libs/libcdaudio-0.99.12-r4
18         x11-libs/libX11"
19 DEPEND="${RDEPEND}
20         x11-libs/libXt"
22 PATCHES=(
23         "${FILESDIR}"/${P}_${PV}a.diff
24         "${FILESDIR}"/${P}-gcc3.3.patch
25         "${FILESDIR}"/${P}-gcc4.3.patch
28 src_prepare() {
29         default
30         eautoreconf
33 src_configure() {
34         append-cxxflags -std=c++14
35         econf \
36                 --with-x \
37                 --x-includes=/usr/include/X11 \
38                 --x-libraries=/usr/lib64/x86_64-linux-gnu
41 src_install() {
42         default
43         rm "${ED}/usr/share/bbtools/README.bbcd" || die