dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / x11-misc / ktsuss / ktsuss-2.1-r1.ebuild
blob87718a586671489371f87be48cc4df8329444bb6
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 DESCRIPTION="Graphical version of su written in C and GTK+ 2"
9 HOMEPAGE="https://github.com/nomius/ktsuss/"
10 SRC_URI="https://github.com/nomius/ktsuss/archive/${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="amd64 ~mips ppc ppc64 x86"
15 IUSE="sudo"
17 RDEPEND="
18         x11-libs/gtk+:2
19         dev-libs/glib:2
20         sudo? ( app-admin/sudo )
21         !sudo? (
22                 || (
23                         sys-apps/util-linux[su]
24                         sys-apps/shadow[su]
25                 )
26         )"
27 DEPEND="${RDEPEND}"
28 BDEPEND="virtual/pkgconfig"
30 DOCS=( Changelog CREDITS README.md )
32 PATCHES=(
33         "${FILESDIR}"/${P}-clang16.patch
34         "${FILESDIR}"/${P}-no-which.patch
37 src_prepare() {
38         default
40         eautoreconf
43 src_configure() {
44         econf $(use_enable sudo)