dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / x11-misc / matchbox-keyboard / matchbox-keyboard-0.1-r2.ebuild
blob8017cd6c4e347583fabbc9e38b3c21a76156d4b0
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard"
9 HOMEPAGE="http://matchbox-project.org/"
10 SRC_URI="http://matchbox-project.org/sources/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~hppa ppc x86"
15 IUSE="debug cairo"
17 DEPEND="
18         x11-libs/libfakekey
19         cairo? ( x11-libs/cairo[X] )
20         !cairo? ( x11-libs/libXft )"
21 RDEPEND="${DEPEND}"
23 PATCHES=( "${FILESDIR}"/${PN}-0.1-r1-modernize_desktop.patch )
25 src_prepare() {
26         default
27         eautoreconf # bug 898250
30 src_configure() {
31         econf \
32                 $(use_enable debug) \
33                 $(use_enable cairo)