dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / x11-misc / obconf-qt / obconf-qt-0.16.5.ebuild
blob237280b6fb3636900d183f8ef81336af440cc522
1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake xdg
8 DESCRIPTION="Qt GUI Openbox Configuration Tool"
9 HOMEPAGE="https://lxqt.github.io/"
11 if [[ ${PV} = *9999* ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
14 else
15         SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
16         KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
19 LICENSE="GPL-2 GPL-2+"
20 SLOT="0"
22 BDEPEND="
23         >=dev-qt/qttools-6.6:6[linguist]
24         >=dev-util/lxqt-build-tools-2.0.0
25         virtual/pkgconfig
27 RDEPEND="
28         dev-libs/glib:2
29         dev-libs/libxml2
30         >=dev-qt/qtbase-6.6:6[gui,widgets]
31         x11-libs/libX11
32         x11-wm/openbox:3
34 DEPEND="${RDEPEND}"