1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
7 CMAKE_IN_SOURCE_BUILD=1
8 PLOCALES="cs_CZ de_DE es_ES fi_FI fr_CA fr_FR it_IT ko_KR nl_NL pl_PL pt_BR ru_RU uk_UA zh_CN"
9 inherit cmake flag-o-matic plocale xdg
11 DESCRIPTION="Viewer for comic book archives containing jpeg/png images"
12 HOMEPAGE="https://github.com/stolowski/QComicBook"
13 SRC_URI="https://github.com/stolowski/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
17 KEYWORDS="amd64 ~ppc x86"
24 dev-qt/qtprintsupport:5
28 BDEPEND="dev-qt/linguist-tools:5"
30 DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
32 S="${WORKDIR}/${MY_PN}-${PV}"
36 rm "i18n/${PN}_${1}.ts" || die "removing ${1} locale failed"
38 rm "i18n/${PN}_en_EN.ts" || die 'removing redundant english locale failed'
39 plocale_find_changes "i18n" "${PN}_" ".ts"
40 plocale_for_each_disabled_locale rm_loc
43 sed -e '/^Encoding/d' \
44 -e '/^Icon/s/.png//' \
45 -e '/^Categories/s/Application;//' \
46 -i data/${PN}.desktop || die 'sed on desktop file failed'
52 use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
58 elog "For using QComicBook with compressed archives you may want to install:"
59 elog " app-arch/p7zip"
60 elog " app-arch/unace"
61 elog " app-arch/unrar or app-arch/rar"
62 elog " app-arch/unzip"