dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / x11-misc / qps / qps-2.9.0.ebuild
blob81536e51c2ec4f0f1af18c5097be0817cc2fa292
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake xdg-utils
8 DESCRIPTION="Qt GUI Process Manager"
9 HOMEPAGE="https://lxqt-project.org/"
11 if [[ ${PV} == 9999 ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
14 else
15         SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
16         KEYWORDS="amd64 arm64 ~ppc64 ~riscv ~x86"
19 LICENSE="GPL-2 GPL-2+ LGPL-2.1+ QPL-1.0"
20 SLOT="0"
22 BDEPEND="
23         >=dev-qt/qttools-6.6:6[linguist]
24         >=dev-util/lxqt-build-tools-2.0.0
26 DEPEND="
27         >=dev-qt/qtbase-6.6:6[gui,widgets]
28         >=lxqt-base/liblxqt-2.0:=
30 RDEPEND="${DEPEND}"
32 pkg_postinst() {
33         xdg_desktop_database_update
34         xdg_icon_cache_update
37 pkg_postrm() {
38         xdg_desktop_database_update
39         xdg_icon_cache_update