dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / x11-misc / skippy / skippy-0.5.0-r2.ebuild
blob519bef1bd83f0940f7de4b93ac1c97d7c0c04123
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit toolchain-funcs
8 DESCRIPTION="A full-screen task-switcher providing Apple Expose-like functionality"
9 HOMEPAGE="http://thegraveyard.org/skippy.php"
10 SRC_URI="http://thegraveyard.org/files/${P}.tar.bz2"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
16 RDEPEND="media-libs/imlib2[X]
17         x11-libs/libXext
18         x11-libs/libX11
19         x11-libs/libXinerama
20         x11-libs/libXmu
21         x11-libs/libXft"
22 DEPEND="${RDEPEND}
23         x11-base/xorg-proto"
24 BDEPEND="virtual/pkgconfig"
26 PATCHES=(
27         "${FILESDIR}"/${PN}-pointer-size.patch
28         "${FILESDIR}"/${P}-Makefile.patch
29         "${FILESDIR}"/${P}-fno-common.patch
30         "${FILESDIR}"/${P}-imlib2-pkg-config.patch
33 DOCS=( CHANGELOG skippyrc-default )
35 src_compile() {
36         tc-export CC PKG_CONFIG
38         default
41 pkg_postinst() {
42         elog
43         elog "You should copy skippyrc-default from /usr/share/doc/${PF} to"
44         elog "~/.skippyrc and edit the keysym used to invoke skippy."
45         elog "Use x11-apps/xev to find out the keysym."
46         elog