dev-python/agate: Bump to 1.13.0
[gentoo/gentoo.git] / x11-misc / wmname / wmname-0.1-r1.ebuild
blobd7e6c152feabfe9aab65812afb8ea05ec3f14360
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit toolchain-funcs
8 DESCRIPTION="Utility to set the name of your window manager"
9 HOMEPAGE="https://tools.suckless.org/x/wmname"
10 SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
16 RDEPEND="x11-libs/libX11"
17 DEPEND="${RDEPEND}"
19 PATCHES=( "${FILESDIR}"/${P}-buildsystem.patch )
21 src_compile() {
22         emake CC="$(tc-getCC)" LD="$(tc-getCC)"
25 src_install() {
26         emake CC="$(tc-getCC)" LD="$(tc-getCC)" \
27                 PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
28         einstalldocs