dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / dev-games / freecell-solver / freecell-solver-6.8.0.ebuild
blob87ab3c18b20da28c0dac089365470b209b393393
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{10..13} )
7 inherit cmake python-single-r1
9 DESCRIPTION="C library for automatically solving Freecell and some other solitaire variants"
10 HOMEPAGE="https://fc-solve.shlomifish.org/"
11 SRC_URI="https://fc-solve.shlomifish.org/downloads/fc-solve/${P}.tar.xz"
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 arm64 ~loong ~riscv x86"
16 IUSE="tcmalloc"
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20 RDEPEND="${PYTHON_DEPS}
21         dev-libs/rinutils
22         $(python_gen_cond_dep '
23                 dev-python/pysol-cards[${PYTHON_USEDEP}]
24                 dev-python/random2[${PYTHON_USEDEP}]
25                 dev-python/six[${PYTHON_USEDEP}]
26         ')
27         tcmalloc? ( dev-util/google-perftools )
29 DEPEND="${RDEPEND}
30         dev-perl/Moo
31         dev-perl/Path-Tiny
32         dev-perl/Template-Toolkit
35 DOCS=( README.html )
37 PATCHES=(
38         "${FILESDIR}/${PN}-5.22.1-no-docs.patch"
39         "${FILESDIR}/${PN}-6.6.0-no-git-clone-kthxbye.patch"
42 src_prepare() {
43         cmake_src_prepare
44         python_fix_shebang board_gen
47 src_configure() {
48         local mycmakeargs=(
49                 -DBUILD_STATIC_LIBRARY=OFF
50                 -DFCS_BUILD_DOCS=OFF
51                 -DFCS_WITH_TEST_SUITE=OFF # requires unpackaged dependencies
52                 -DFCS_AVOID_TCMALLOC=$(usex !tcmalloc)
53         )
55         cmake_src_configure