dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / dev-java / open-test-reporting-schema / open-test-reporting-schema-0.1.0_pre1.ebuild
blob6cab8a063da8d5bd69d0374d156d6f92e69c52f8
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 JAVA_PKG_IUSE="doc source"
7 MAVEN_ID="org.opentest4j.reporting:open-test-reporting-schema:0.1.0-M1"
9 inherit java-pkg-2 java-pkg-simple
11 DESCRIPTION="Language-agnostic test reporting format and tooling"
12 HOMEPAGE="https://github.com/ota4j-team/open-test-reporting"
13 MY_PV="${PV/_pre/-M}"
14 SRC_URI="https://github.com/ota4j-team/open-test-reporting/archive/r${MY_PV}.tar.gz -> open-test-reporting-${MY_PV}.tar.gz"
15 S="${WORKDIR}/open-test-reporting-r${MY_PV}/schema"
17 LICENSE="Apache-2.0"
18 SLOT="0"
19 KEYWORDS="amd64 arm64 ppc64"
21 RDEPEND=">=virtual/jre-1.8:*"
22 DEPEND=">=virtual/jdk-1.8:*"
24 JAVA_SRC_DIR="src/main/java"
25 JAVA_RESOURCE_DIRS="src/main/resources"
26 JAVA_AUTOMATIC_MODULE_NAME="org.opentest4j.reporting.schema"