dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / media-video / devedeng / devedeng-4.19.0.ebuild
blobd76b88ce00bae72e9de3173532e76678aa46adb5
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{9..13} )
9 inherit distutils-r1 xdg
11 DESCRIPTION="DevedeNG is a program to create video DVDs and CDs (VCD, sVCD or CVD)"
12 HOMEPAGE="https://www.rastersoft.com/programas/devede.html"
13 SRC_URI="https://gitlab.com/rastersoft/${PN}/-/archive/${PV}/${P}.tar.bz2"
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
19 RDEPEND="
20         app-cdr/cdrtools
21         dev-python/pycairo[${PYTHON_USEDEP}]
22         dev-python/pygobject:3[${PYTHON_USEDEP}]
23         x11-libs/gtk+:3
24         || ( media-video/vlc media-video/mpv media-video/mplayer )
25         media-video/ffmpeg
26         media-video/dvdauthor
27         media-video/vcdimager
28         || ( app-cdr/brasero kde-apps/k3b app-cdr/xfburn )"
30 DEPEND="${PYTHON_DEPS}"
32 # src/unitests only works against system installed devedeng
33 RESTRICT="test"
35 src_prepare() {
36         default
38         # Documentation path
39         #sed -e "s#/usr/share/doc/devedeng#/usr/share/doc/${PF}#" \
40         #       -i src/devedeng/configuration_data.py || die
41         #sed -e "/'doc'/s/devedeng/${PF}/" -i setup.py || die
43         # Desktop icon
44         sed -e "/^Icon/s/.svg$//#" -i src/devedeng/data/devede_ng.desktop || die