dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / media-video / webcamoid / webcamoid-9999.ebuild
blob2bcfa8ebd3432db90d3351807e56e29c5f62b27d
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake flag-o-matic xdg
8 DESCRIPTION="Full featured webcam capture application"
9 HOMEPAGE="https://webcamoid.github.io"
10 if [[ ${PV} = 9999 ]]; then
11         EGIT_REPO_URI="https://github.com/webcamoid/webcamoid.git"
12         EGIT_BRANCH="master"
13         inherit git-r3
14         RESTRICT="mirror"
15 else
16         SRC_URI="https://github.com/webcamoid/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
17         KEYWORDS="~amd64 ~arm64 ~x86"
20 LICENSE="GPL-3"
21 SLOT="0"
22 IUSE="alsa ffmpeg gstreamer jack libuvc oss portaudio pulseaudio qtaudio qtcamera sdl v4lutils videoeffects debug headers v4l"
24 REQUIRED_USE="v4lutils? ( v4l )"
26 COMMON_DEPEND="
27         dev-qt/qtbase:6[concurrent,dbus,gui,network,opengl,widgets]
28         dev-qt/qtdeclarative:6
29         dev-qt/qtsvg:6
30         ffmpeg? ( media-video/ffmpeg:= )
31         gstreamer? ( >=media-libs/gstreamer-1.6.0 )
32         jack? ( virtual/jack )
33         libuvc? ( media-libs/libuvc )
34         pulseaudio? ( media-libs/libpulse )
35         qtaudio? ( dev-qt/qtmultimedia:6 )
36         qtcamera? ( dev-qt/qtmultimedia:6 )
37         sdl? ( media-libs/libsdl2 )
38         v4l? ( media-libs/libv4l )
40 DEPEND="${COMMON_DEPEND}
41         >=sys-kernel/linux-headers-3.6
43 RDEPEND="${COMMON_DEPEND}
44         virtual/opengl
47 src_configure() {
48         # -Werror=odr
49         # https://bugs.gentoo.org/927104
50         # https://github.com/webcamoid/webcamoid/issues/702
51         filter-lto
53         #Disable git in package source. If not disabled the cmake configure process will show
54         #a lot of "fatal not a git repository" errors
55         sed -i 's|find_program(GIT_BIN git)|#find_program(GIT_BIN git)|' libAvKys/cmake/ProjectCommons.cmake || die
57         local mycmakeargs=(
58                 "-DNOMEDIAFOUNDATION=1"
59                 "-DNODSHOW=1"
60                 "-DNOWASAPI=1"
61                 "-DNOVLC=1"
62                 "-DNOPIPEWIRE=1"
63                 "-DNOPORTAUDIO=1" # PortAudio not packaged for gentoo
64                 "-DNOALSA=$(usex alsa 0 1)"
65                 "-DNOQTAUDIO=$(usex qtaudio 0 1)"
66                 "-DNOQTCAMERA=$(usex qtcamera 0 1)"
67                 "-DNOFFMPEG=$(usex ffmpeg 0 1)"
68                 "-DNOGSTREAMER=$(usex gstreamer 0 1)"
69                 "-DNOJACK=$(usex jack 0 1)"
70                 "-DNOLIBUVC=$(usex libuvc 0 1)"
71                 "-DNOPULSEAUDIO=$(usex pulseaudio 0 1)"
72                 "-DNOSDL=$(usex sdl 0 1)"
73                 "-DNOV4L2=$(usex v4l 0 1)"
74                 "-DNOV4LUTILS=$(usex v4lutils 0 1)"
75                 "-DNOVIDEOEFFECTS=$(usex videoeffects 0 1)"
76         )
77         cmake_src_configure
80 src_install() {
81         docompress -x /usr/share/man/man1/${PN}.1.gz
82         cmake_src_install