dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / sci-electronics / sigrok-cli / sigrok-cli-9999.ebuild
blob9f8ce64111d05a3226fe3eb5c1d66697c0974d84
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI="8"
6 inherit xdg-utils
8 if [[ ${PV} == "9999" ]]; then
9         EGIT_REPO_URI="https://github.com/sigrokproject/${PN}.git"
10         inherit git-r3 autotools
11 else
12         SRC_URI="https://sigrok.org/download/source/${PN}/${P}.tar.gz"
13         KEYWORDS="~amd64 ~x86"
16 DESCRIPTION="Command-line client for the sigrok logic analyzer software"
17 HOMEPAGE="https://sigrok.org/wiki/Sigrok-cli"
19 LICENSE="GPL-3"
20 SLOT="0"
21 IUSE="+decode"
23 RDEPEND=">=dev-libs/glib-2.32.0
24         >=sci-libs/libsigrok-0.5.0:=
25         decode? ( >=sci-libs/libsigrokdecode-0.5.0:= )"
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig"
29 src_prepare() {
30         [[ ${PV} == "9999" ]] && eautoreconf
31         eapply_user
34 src_configure() {
35         econf $(use_with decode libsigrokdecode)
38 pkg_postinst() {
39         xdg_icon_cache_update
40         xdg_desktop_database_update
43 pkg_postrm() {
44         xdg_icon_cache_update
45         xdg_desktop_database_update