1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 if [[ ${PV} == "9999" ]]; then
9 EGIT_REPO_URI="https://github.com/sigrokproject/${PN}.git"
10 inherit git-r3 autotools
12 SRC_URI="https://sigrok.org/download/source/${PN}/${P}.tar.gz"
13 KEYWORDS="~amd64 ~x86"
16 DESCRIPTION="Command-line client for the sigrok logic analyzer software"
17 HOMEPAGE="https://sigrok.org/wiki/Sigrok-cli"
23 RDEPEND=">=dev-libs/glib-2.32.0
24 >=sci-libs/libsigrok-0.5.0:=
25 decode? ( >=sci-libs/libsigrokdecode-0.5.0:= )"
30 [[ ${PV} == "9999" ]] && eautoreconf
35 econf $(use_with decode libsigrokdecode)
40 xdg_desktop_database_update
45 xdg_desktop_database_update