1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit toolchain-funcs
8 DESCRIPTION="RF Signal Propagation, Loss, And Terrain analysis tool"
9 HOMEPAGE="https://www.qsl.net/kd2bd/splat.html"
10 SRC_URI="https://www.qsl.net/kd2bd/${P}.tar.bz2"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE="doc hires l10n_es"
24 "${FILESDIR}"/${PN}-1.2.2-gcc43.patch
28 # fake resulting file from interactive configuration script
29 # using default resolution
30 cat <<- EOF > "${S}/splat.h" || die
31 /* Parameters for 3 arc-second standard resolution mode of operation */
36 # fake resulting file from interactive configuration script
37 # using default resolution
38 cat <<- EOF > "${S}/hires.h" || die
39 /* Parameters for 3 arc-second hires resolution mode of operation */
49 cp {splat,rfsplat}.cpp || die
50 emake LDLIBS="-lm -lbz2" -E "rfsplat: itwom3.0.o"
52 cp {hires,splat}.h || die
53 cp {splat,rfsplat-hd}.cpp || die
54 emake LDLIBS="-lm -lbz2" -E "rfsplat-hd: itwom3.0.o"
59 emake citydecoder usgs2sdf
60 emake LDLIBS=-lbz2 srtm2sdf
61 emake LDLIBS=-lm bearing
65 local SPLAT_LANG="english"
66 use l10n_es && SPLAT_LANG="spanish"
70 use hires && dobin rfsplat-hd
73 dobin utils/{citydecoder,usgs2sdf,srtm2sdf,postdownload,bearing}
74 newman docs/${SPLAT_LANG}/man/splat.man rfsplat.1
76 dodoc CHANGES README utils/fips.txt
77 newdoc utils/README README.UTILS
79 use doc && dodoc docs/${SPLAT_LANG}/{pdf/splat.pdf,postscript/splat.ps}
83 dodoc -r sample_data/.
87 elog "The original SPLAT! command got renamed to 'rfsplat' to avoid"
88 elog "filename collision with app-portage/splat."
90 elog "Be aware that it is still referenced as 'splat' in the documentation."