1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit flag-o-matic toolchain-funcs
8 DESCRIPTION="An Automated Deduction System"
9 HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
10 SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
14 KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
23 "${FILESDIR}"/${P}-build.patch
24 "${FILESDIR}"/${P}-gold.patch
25 "${FILESDIR}"/${P}-clang16.patch
29 append-cflags -fcommon
30 append-cflags -std=gnu89 # old codebase, incompatible with c2x
31 append-cppflags -D_GNU_SOURCE #871423 (gethostname, caddr_t)
42 dobin bin/* source/formed/formed
44 dodoc README* Legal Changelog Contents documents/*.pdf
46 insinto /usr/share/${PN}
47 doins -r examples examples-mace2