dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / sci-mathematics / otter / otter-3.3-r4.ebuild
blob711bc9eae5387a4749784fbbc951c1abad05d006
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit flag-o-matic toolchain-funcs
8 DESCRIPTION="An Automated Deduction System"
9 HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
10 SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
12 LICENSE="otter"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
16 RDEPEND="
17         x11-libs/libX11
18         x11-libs/libXaw
19         x11-libs/libXt"
20 DEPEND="${RDEPEND}"
22 PATCHES=(
23         "${FILESDIR}"/${P}-build.patch
24         "${FILESDIR}"/${P}-gold.patch
25         "${FILESDIR}"/${P}-clang16.patch
28 src_configure() {
29         append-cflags -fcommon
30         append-cflags -std=gnu89 # old codebase, incompatible with c2x
31         append-cppflags -D_GNU_SOURCE #871423 (gethostname, caddr_t)
34 src_compile() {
35         tc-export AR CC
37         emake -C source
38         emake -C mace2
41 src_install() {
42         dobin bin/* source/formed/formed
44         dodoc README* Legal Changelog Contents documents/*.pdf
46         insinto /usr/share/${PN}
47         doins -r examples examples-mace2