dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / sys-apps / dcfldd / dcfldd-1.9.2.ebuild
blob02b59ea3d7de6ff20be12eba340354edd724a121
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit autotools bash-completion-r1
7 DESCRIPTION="enhanced dd with features for forensics and security"
8 HOMEPAGE="https://github.com/resurrecting-open-source-projects/dcfldd"
9 SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~ppc ~riscv x86"
15 DEPEND="virtual/pkgconfig"
17 DOCS=(
18         AUTHORS
19         CONTRIBUTING.md
20         ChangeLog
21         NEWS
22         README.md
25 src_prepare() {
26         default
27         eautoreconf
30 src_configure() {
31         econf --with-bash-completion
34 src_install() {
35         default
37         # Fix Bash completion filename
38         mv "${D}$(get_bashcompdir)"/dcfldd{-bash_completion,} || die