dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / sys-block / whdd / whdd-3.1.ebuild
blobcc512b2ae7612f7e1ef2ceadaa704faa1b4b7060
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="Diagnostic and recovery tool for block devices"
7 HOMEPAGE="https://whdd.github.io"
9 inherit toolchain-funcs
11 if [[ ${PV} == 9999 ]]
12 then
13         EGIT_REPO_URI="https://github.com/${PN}/${PN}"
14         inherit git-r3
15 else
16         SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}-rel.tar.gz"
17         KEYWORDS="amd64 ~riscv ~x86"
20 LICENSE="GPL-3"
21 SLOT="0"
23 DEPEND="dev-util/dialog:=
24         sys-libs/ncurses:=[unicode(+)]"
25 RDEPEND="${DEPEND}
26         sys-apps/smartmontools"
28 src_compile() {
29         tc-export CC
30         default
33 src_install() {
34         emake DESTDIR="${ED}" install
35         einstalldocs