dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / x11-wm / cwm / cwm-6.7.ebuild
blobe072dd64c419af21aeed0e9ef89603ca0c4eed85
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit desktop toolchain-funcs
8 DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
9 HOMEPAGE="https://github.com/leahneukirchen/cwm
10         https://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
13 if [[ ${PV} == 9999 ]]; then
14         inherit git-r3
15         EGIT_REPO_URI="https://github.com/leahneukirchen/cwm.git"
16 else
17         SRC_URI="https://github.com/leahneukirchen/cwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
18         KEYWORDS="amd64 arm ~arm64 x86"
21 LICENSE="ISC"
22 SLOT="0"
24 DEPEND="x11-libs/libXft
25         x11-libs/libXinerama
26         x11-libs/libXrandr
28 RDEPEND="${DEPEND}"
29 BDEPEND="
30         app-alternatives/yacc
31         virtual/pkgconfig
34 src_compile() {
35         emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
38 src_install() {
39         emake DESTDIR="${D}" PREFIX=/usr install
40         dodoc README
41         make_session_desktop ${PN} ${PN}