1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop toolchain-funcs
8 DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
9 HOMEPAGE="https://github.com/leahneukirchen/cwm
10 https://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
13 if [[ ${PV} == 9999 ]]; then
15 EGIT_REPO_URI="https://github.com/leahneukirchen/cwm.git"
17 SRC_URI="https://github.com/leahneukirchen/cwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
18 KEYWORDS="amd64 arm ~arm64 x86"
24 DEPEND="x11-libs/libXft
35 emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
39 emake DESTDIR="${D}" PREFIX=/usr install
41 make_session_desktop ${PN} ${PN}