dev-python/mpmath: Bump to 1.4.0_alpha4
[gentoo/gentoo.git] / x11-wm / cwm / cwm-7.4.ebuild
blob1b85c26ff5d76c7e33c2a829ee37aad9cd2b8e2e
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop toolchain-funcs
8 DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
9 HOMEPAGE="https://github.com/leahneukirchen/cwm"
11 if [[ ${PV} == 9999 ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/leahneukirchen/cwm.git"
14 else
15         SRC_URI="https://github.com/leahneukirchen/cwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16         KEYWORDS="amd64 arm ~arm64 ~riscv x86"
19 LICENSE="ISC"
20 SLOT="0"
22 DEPEND="x11-libs/libX11
23         x11-libs/libXft
24         x11-libs/libXrandr
26 RDEPEND="${DEPEND}"
27 BDEPEND="
28         app-alternatives/yacc
29         virtual/pkgconfig
32 src_compile() {
33         emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
36 src_install() {
37         emake DESTDIR="${D}" PREFIX=/usr install
38         dodoc README
39         make_session_desktop ${PN} ${PN}