1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop toolchain-funcs
8 DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
9 HOMEPAGE="https://github.com/leahneukirchen/cwm"
11 if [[ ${PV} == 9999 ]]; then
13 EGIT_REPO_URI="https://github.com/leahneukirchen/cwm.git"
15 SRC_URI="https://github.com/leahneukirchen/cwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 KEYWORDS="amd64 arm ~arm64 ~riscv x86"
22 DEPEND="x11-libs/libX11
33 emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
37 emake DESTDIR="${D}" PREFIX=/usr install
39 make_session_desktop ${PN} ${PN}