app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / app-admin / ansible / ansible-11.0.0.ebuild
blobc56770f055fb6e79d3adb36d706643f31fa99571
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{11..12} )
9 inherit distutils-r1 pypi
11 DESCRIPTION="Model-driven deployment, config management, and command execution framework"
12 HOMEPAGE="https://www.ansible.com/"
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
17 RESTRICT="test"
19 RDEPEND=">=app-admin/ansible-core-2.18.0
20         <app-admin/ansible-core-2.19"
22 python_compile() {
23         local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
24         distutils-r1_python_compile
26 python_install() {
27         local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
28         distutils-r1_python_install