app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / app-crypt / acme-sh / acme-sh-3.1.0.ebuild
blob541a699d4997be3b1c67a25947756c6523cba93d
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN="${PN/-/.}"
7 MY_P="${MY_PN}-${PV}"
9 inherit optfeature
11 DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
12 HOMEPAGE="https://github.com/acmesh-official/acme.sh"
13 SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${MY_P}.tar.gz"
14 S="${WORKDIR}/${MY_P}"
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
20 IUSE="selinux"
22 RDEPEND="
23         dev-libs/openssl:0
24         net-misc/curl
25         net-misc/socat
26         selinux? ( sec-policy/selinux-certbot )
29 src_install() {
30         newdoc deploy/README.md README-deploy.md
31         newdoc dnsapi/README.md README-dnsapi.md
32         rm {deploy,dnsapi}/README.md || die
33         einstalldocs
35         exeinto /usr/share/acme.sh
36         doexe acme.sh
38         insinto /usr/share/acme.sh
39         doins -r deploy dnsapi notify
41         keepdir /etc/acme-sh
42         doenvd "${FILESDIR}"/99acme-sh
44         insinto /etc/bash/bashrc.d
45         doins "${FILESDIR}"/acme.sh
47         dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
50 pkg_postinst() {
51         optfeature_header "For webserver mode, install a supported web server:"
52         optfeature "using apache2 webserver mode" www-servers/apache
53         optfeature "using nginx webserver mode" www-servers/nginx