1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{10..13} )
11 if [[ "${PV}" == *9999 ]]; then
14 EGIT_REPO_URI="https://github.com/certbot/certbot.git"
16 EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
19 https://github.com/certbot/certbot/archive/v${PV}.tar.gz
22 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
25 DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
27 https://github.com/certbot/certbot/
28 https://pypi.org/project/certbot/
29 https://letsencrypt.org/
32 S="${WORKDIR}/${P}/${PN}"
40 dev-python/typing-extensions[${PYTHON_USEDEP}]
44 # See certbot/setup.py for acme >= dep
46 >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
47 >=dev-python/configargparse-1.5.3[${PYTHON_USEDEP}]
48 >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
49 >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
50 >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
51 >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
52 <dev-python/josepy-2[${PYTHON_USEDEP}]
53 >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
54 dev-python/pyrfc3339[${PYTHON_USEDEP}]
55 >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
56 selinux? ( sec-policy/selinux-certbot )
59 distutils_enable_sphinx docs \
60 dev-python/sphinx-rtd-theme
61 distutils_enable_tests pytest
64 local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1