1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit flag-o-matic toolchain-funcs
8 DESCRIPTION="Offline Windows NT Password & Registry Editor"
9 HOMEPAGE="https://pogostick.net/~pnh/ntpasswd/"
10 SRC_URI="https://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
12 LICENSE="GPL-2 LGPL-2.1"
14 KEYWORDS="amd64 ppc x86"
17 RDEPEND="dev-libs/openssl:0="
20 static? ( dev-libs/openssl:0[static-libs] )"
30 "${FILESDIR}"/${P}-missing-stdint.patch
35 sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
37 # MANY changes would be required for this code to be c99-compliant
38 append-flags -std=gnu90
40 if ! use static ; then
41 sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
50 CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
56 dobin chntpw cpnt reged sampasswd samusrgrp
59 dobin {chntpw,reged,sampasswd,samusrgrp}.static