1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools flag-o-matic
8 DESCRIPTION="An advanced suite for testing the randomness of RNGs"
9 HOMEPAGE="https://www.phy.duke.edu/~rgb/General/dieharder.php"
10 SRC_URI="https://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
14 KEYWORDS="~alpha amd64 arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc x86"
16 RESTRICT="test" # Way too long
18 RDEPEND="sci-libs/gsl:="
20 BDEPEND=" doc? ( dev-tex/latex2html )"
23 "${FILESDIR}"/${P}-build.patch
24 "${FILESDIR}"/${P}-urandom-64bit.patch
25 "${FILESDIR}"/${P}-cross-compile.patch
35 econf --disable-static
40 use doc && emake -C manual
45 DOCS=( ChangeLog manual/dieharder.pdf manual/dieharder.ps )
46 HTML_DOCS=( dieharder.html )
52 dodoc dieharder/{NOTES,README}
54 dodoc libdieharder/{NOTES,README}
56 find "${ED}" -name '*.la' -delete || die