app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / app-crypt / dieharder / dieharder-3.31.1-r4.ebuild
blob66653aaa6ebba5f7a6092f068d97f226c02ca29f
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools flag-o-matic
8 DESCRIPTION="An advanced suite for testing the randomness of RNGs"
9 HOMEPAGE="https://www.phy.duke.edu/~rgb/General/dieharder.php"
10 SRC_URI="https://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc x86"
15 IUSE="doc"
16 RESTRICT="test" # Way too long
18 RDEPEND="sci-libs/gsl:="
19 DEPEND="${RDEPEND}"
20 BDEPEND=" doc? ( dev-tex/latex2html )"
22 PATCHES=(
23         "${FILESDIR}"/${P}-build.patch
24         "${FILESDIR}"/${P}-urandom-64bit.patch
25         "${FILESDIR}"/${P}-cross-compile.patch
28 src_prepare() {
29         default
30         eautoreconf
33 src_configure() {
34         append-flags -fcommon
35         econf --disable-static
38 src_compile() {
39         emake -j1
40         use doc && emake -C manual
43 src_install() {
44         if use doc; then
45                 DOCS=( ChangeLog manual/dieharder.pdf manual/dieharder.ps )
46                 HTML_DOCS=( dieharder.html )
47         fi
49         default
51         docinto dieharder
52         dodoc dieharder/{NOTES,README}
53         docinto libdieharder
54         dodoc libdieharder/{NOTES,README}
56         find "${ED}" -name '*.la' -delete || die