1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit toolchain-funcs
8 DESCRIPTION="A free, pretty much fully featured and stable TrueCrypt implementation"
9 HOMEPAGE="https://github.com/bwalex/tc-play"
10 SRC_URI="https://github.com/bwalex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
22 gnutls? ( net-libs/gnutls )
32 "${FILESDIR}"/${PN}-3.3-ldflags.patch
36 local backend="openssl"
37 use gnutls && local backend="gcrypt"
40 PBKDF_BACKEND="${backend}"
45 LIBDIR=/usr/$(get_libdir)
50 emake -f Makefile.classic \
52 "${EXTRA_MAKE_FLAGS[@]}"
56 emake -f Makefile.classic \
57 "${EXTRA_MAKE_FLAGS[@]}" \