app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / app-crypt / tpm2-openssl / tpm2-openssl-1.2.0.ebuild
blob03767401d089492b91fdb82ccf2c7a7f534ce860
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 DESCRIPTION="OpenSSL Provider for TPM2 integration"
9 HOMEPAGE="https://github.com/tpm2-software/tpm2-openssl"
10 SRC_URI="https://github.com/tpm2-software/tpm2-openssl/releases/download/${PV}/${P}.tar.gz"
12 LICENSE="BSD"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
18 RDEPEND="
19         >=app-crypt/tpm2-tss-3.2.0:=
20         >=dev-libs/openssl-3:="
21 DEPEND="${RDEPEND}
22         test? (
23                 app-crypt/swtpm[gnutls(+)]
24                 app-crypt/tpm2-abrmd
25                 app-crypt/tpm2-tools
26         )"
27 BDEPEND="
28         dev-build/autoconf-archive
29         virtual/pkgconfig"
31 PATCHES=(
32         "${FILESDIR}/${PN}-1.2.0-tests-run-with-simulator-in-container.patch"
33         "${FILESDIR}/${PN}-1.2.0-Makefile-add-run-with-simulator-to-extra-dists.patch"
34         "${FILESDIR}/${PN}-1.1.1-build-Fix-undefined-references-when-using-slibtool.patch"
37 src_prepare() {
38         default
39         eautoreconf
42 src_test() {
43         "${S}/test/run-with-simulator" swtpm skip-build || die
46 src_install() {
47         default
48         find "${ED}" -iname '*.la' -delete || die