1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit readme.gentoo-r1
8 DESCRIPTION="Android DEvice Backup And Report, using Bash and ADB"
9 HOMEPAGE="https://codeberg.org/izzy/Adebar"
10 SRC_URI="https://codeberg.org/izzy/Adebar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
20 dev-util/android-tools
23 DISABLE_AUTOFORMATTING="no"
24 DOC_CONTENTS="Please refer to the documentation at https://codeberg.org/izzy/Adebar/wiki.
25 You can find example configurations at /usr/share/doc/${PF}.
26 To customize, copy to \${XDG_CONFIG_HOME}/${PN} and edit it to your liking.
27 Contrary to the documentation, the Gentoo installation does not allow
28 configuration files relative to main program ${PN} installed to /usr/bin.
29 So the documentation must be placed in the users home directory."
34 sed -i -e 's|\(BINDIR=\).*|\1"/usr/share/adebar"|' ${PN}-cli
35 sed -i -e 's|\(LIBDIR=\).*|\1"/usr/lib/adebar"|' ${PN}-cli
36 sed -i -e '/-d "\$HOME\/\.config\/adebar"/,+2d' ${PN}-cli
40 local libdir=/usr/lib/${PN}
41 local sharedir=/usr/share/${PN}
43 newbin ${PN}-cli ${PN}
48 exeinto ${sharedir}/tools
50 fperms 0644 ${sharedir}/tools/xml2array.php
52 insinto ${sharedir}/templates
58 readme.gentoo_create_doc
62 readme.gentoo_print_elog