app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / app-mobilephone / adebar / adebar-2.4.1.ebuild
blob3d44674e47c8bf6d56ca6f37660d9fbccd47d53e
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit readme.gentoo-r1
8 DESCRIPTION="Android DEvice Backup And Report, using Bash and ADB"
9 HOMEPAGE="https://codeberg.org/izzy/Adebar"
10 SRC_URI="https://codeberg.org/izzy/Adebar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 S="${WORKDIR}/${PN}"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 RDEPEND="
19         app-shells/bash
20         dev-util/android-tools
23 DISABLE_AUTOFORMATTING="no"
24 DOC_CONTENTS="Please refer to the documentation at https://codeberg.org/izzy/Adebar/wiki.
25 You can find example configurations at /usr/share/doc/${PF}.
26 To customize, copy to \${XDG_CONFIG_HOME}/${PN} and edit it to your liking.
27 Contrary to the documentation, the Gentoo installation does not allow
28 configuration files relative to main program ${PN} installed to /usr/bin.
29 So the documentation must be placed in the users home directory."
31 src_prepare() {
32         default
34         sed -i -e 's|\(BINDIR=\).*|\1"/usr/share/adebar"|' ${PN}-cli
35         sed -i -e 's|\(LIBDIR=\).*|\1"/usr/lib/adebar"|' ${PN}-cli
36         sed -i -e '/-d "\$HOME\/\.config\/adebar"/,+2d' ${PN}-cli
39 src_install() {
40         local libdir=/usr/lib/${PN}
41         local sharedir=/usr/share/${PN}
43         newbin ${PN}-cli ${PN}
45         insinto ${libdir}
46         doins -r lib/*
48         exeinto ${sharedir}/tools
49         doexe tools/*
50         fperms 0644 ${sharedir}/tools/xml2array.php
52         insinto ${sharedir}/templates
53         doins -r templates/*
55         dodoc -r doc/*
56         dodoc README.md
58         readme.gentoo_create_doc
61 pkg_postinst() {
62         readme.gentoo_print_elog