app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / app-mobilephone / scmxx / scmxx-0.9.0-r1.ebuild
blobf713abcbf405f82333f55c46d240930aab206acb
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 DESCRIPTION="Exchange data with Siemens phones"
9 HOMEPAGE="http://www.hendrik-sattler.de/scmxx/"
10 SRC_URI="https://downloads.sourceforge.net/scmxx/${P}.tar.bz2"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 x86"
15 IUSE="bluetooth nls"
17 RDEPEND="bluetooth? ( net-wireless/bluez )"
18 DEPEND="${RDEPEND}"
19 BDEPEND="nls? ( sys-devel/gettext )"
21 src_prepare() {
22         default
24         # Clang 16
25         eautoreconf
28 src_install() {
29         default
31         exeinto /usr/lib/scmxx
32         doexe contrib/*
34         doman docs/*.1
36         rm docs/README_WIN32.txt || die
37         dodoc AUTHORS BUGS CHANGELOG README TODO docs/*.txt