www-apache/mod_tls: new package, add 0.14.0
[gentoo/gentoo.git] / dev-cpp / ETL / ETL-1.4.1.ebuild
blob2ee1d06fea4ceb6760f78beb26e9be106961eda4
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools
8 DESCRIPTION="Multi-platform class and template library"
9 HOMEPAGE="https://www.synfig.org"
10 SRC_URI="https://github.com/synfig/synfig/releases/download/v${PV}/${P}.tar.gz"
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 RDEPEND=">=dev-cpp/glibmm-2.24.2:2"
16 DEPEND="${RDEPEND}"
18 src_prepare() {
19         default
20         sed -i -e 's/CXXFLAGS="`echo $CXXFLAGS | sed s:-g::` $debug_flags"//' \
21                 -e 's/CFLAGS="`echo $CFLAGS | sed s:-g::` $debug_flags"//'     \
22                 m4/subs.m4 || die
23         sed -i -e 's/hermite<angle>/etl::&/' test/angle.cpp
25         eautoreconf