www-apache/mod_tls: new package, add 0.14.0
[gentoo/gentoo.git] / dev-cpp / expected-lite / expected-lite-0.6.3.ebuild
blobc21d55efda0d5eea9f01cf6f188169a890fbc466
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake
8 DESCRIPTION="Expected objects in C++11 and later in a single-file header-only library"
9 HOMEPAGE="https://github.com/martinmoene/expected-lite"
11 SRC_URI="https://github.com/martinmoene/expected-lite/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="Boost-1.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 ~loong ~ppc64 ~riscv"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
19 src_configure() {
20         local mycmakeargs=(
21                 -DEXPECTED_LITE_OPT_BUILD_TESTS=$(usex test)
22         )
24         cmake_src_configure