1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit cmake-multilib flag-o-matic
8 if [[ ${PV} == *9999* ]]; then
10 EGIT_REPO_URI="https://github.com/gflags/gflags"
12 SRC_URI="https://github.com/gflags/gflags/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
16 DESCRIPTION="Google's C++ argument parsing library"
17 HOMEPAGE="https://gflags.github.io/gflags/"
21 IUSE="static-libs test"
22 RESTRICT="!test? ( test )"
24 # AUTHORS.txt only links the google group
25 DOCS=( ChangeLog.txt README.md )
27 multilib_src_configure() {
31 -DBUILD_STATIC_LIBS=$(usex static-libs)
32 -DBUILD_TESTING=$(usex test)
33 # avoid installing .cmake/packages, e.g.:
34 # >>> /tmp/portage/dev-cpp/gflags-9999/homedir/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9
35 -DREGISTER_INSTALL_PREFIX=OFF