1 # Copyright 2011-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 if [[ "${PV}" == "9999" ]]; then
11 EGIT_REPO_URI="https://github.com/google/glog"
14 DESCRIPTION="Google Logging library"
15 HOMEPAGE="https://github.com/google/glog"
16 if [[ "${PV}" == "9999" ]]; then
19 SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
24 KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ~mips ppc ~ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
25 IUSE="gflags +libunwind llvm-libunwind test"
26 RESTRICT="!test? ( test )"
28 RDEPEND="gflags? ( dev-cpp/gflags:0=[${MULTILIB_USEDEP}] )
30 llvm-libunwind? ( llvm-runtimes/libunwind:0=[${MULTILIB_USEDEP}] )
31 !llvm-libunwind? ( sys-libs/libunwind:0=[${MULTILIB_USEDEP}] )
35 test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )
39 "${FILESDIR}/${P}-disable-symbolize-test.patch" # bug 863599
40 "${FILESDIR}/${P}-try-fix-logging-test.patch"
45 -DBUILD_TESTING=$(usex test ON OFF)
46 -DWITH_GFLAGS=$(usex gflags ON OFF)
47 -DWITH_GTEST=$(usex test ON OFF)
48 -DWITH_UNWIND=$(usex libunwind ON OFF)
51 cmake-multilib_src_configure
55 cmake-multilib_src_test -j1