www-apache/mod_tls: new package, add 0.14.0
[gentoo/gentoo.git] / dev-cpp / ms-gsl / ms-gsl-9999.ebuild
blob79f60335475e4e58c2493868f1e35c7a1d90b9cb
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake git-r3
8 DESCRIPTION="Guideline Support Library implementation by Microsoft"
9 HOMEPAGE="https://github.com/Microsoft/GSL"
10 SRC_URI=""
11 EGIT_REPO_URI="https://github.com/Microsoft/GSL.git"
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="test"
17 RESTRICT="!test? ( test )"
19 # header only library
20 RDEPEND=""
21 DEPEND="test? ( >=dev-cpp/gtest-1.9.0_pre20190607 )"
23 PATCHES=(
24         "${FILESDIR}/${PN}-1.0.0-disable_Werror-644042.patch"
27 src_configure() {
28         local mycmakeargs=(
29                 -DGSL_TEST=$(usex test)
30         )
31         cmake_src_configure