www-apache/mod_tls: new package, add 0.14.0
[gentoo/gentoo.git] / dev-haskell / cmdargs / cmdargs-0.10.20.ebuild
blobf40d8d9fae73cfaf43591552aee7ab14a1aa9a64
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 # ebuild generated by hackport 0.5.6
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
11 DESCRIPTION="Command line argument processing"
12 HOMEPAGE="https://github.com/ndmitchell/cmdargs#readme"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
18 IUSE="+quotation testprog"
20 RDEPEND=">=dev-haskell/semigroups-0.18:=[profile?]
21         >=dev-lang/ghc-7.8.2:=
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.18.1.3
27 src_configure() {
28         haskell-cabal_src_configure \
29                 $(cabal_flag quotation quotation) \
30                 $(cabal_flag testprog testprog)