app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / dev-haskell / colour / colour-2.3.6.ebuild
blob5095e74b2b593205e484281a83465296aebb673d
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 # ebuild generated by hackport 0.8.0.0.9999
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
11 DESCRIPTION="A model for human colour/color perception"
12 HOMEPAGE="https://www.haskell.org/haskellwiki/Colour"
14 LICENSE="MIT"
15 SLOT="0/${PV}"
16 KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
18 CABAL_CHDEPS=(
19         'random >= 1.0 && < 1.2' 'random >= 1.0'
22 RDEPEND="
23         >=dev-lang/ghc-8.8.1:=
25 DEPEND="${RDEPEND}
26         >=dev-haskell/cabal-3.0.0.0
27         test? (
28                 >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-2.15
29                 >=dev-haskell/random-1.0
30                 >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
31                 >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4
32         )
35 pkg_pretend() {
36         if use test; then
37                 ewarn "The \"test\" USE flag for this package creates cycles within the"
38                 ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
39                 ewarn "It is recommended to leave it disabled unless explicitly testing the package."
40         fi