www-apache/mod_tls: new package, add 0.14.0
[gentoo/gentoo.git] / dev-haskell / hspec-core / hspec-core-2.10.6.ebuild
blob1b54214140c18a7cf76c003dfd874d318b751951
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 # ebuild generated by hackport 0.7.3.0
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
11 DESCRIPTION="A Testing Framework for Haskell"
12 HOMEPAGE="https://hspec.github.io/"
14 LICENSE="MIT"
15 SLOT="0/${PV}"
16 KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
18 RDEPEND=">=dev-haskell/ansi-terminal-0.6.2:=[profile?]
19         >=dev-haskell/call-stack-0.2.0:=[profile?]
20         >=dev-haskell/hspec-expectations-0.8.2:=[profile?] <dev-haskell/hspec-expectations-0.8.3:=[profile?]
21         >=dev-haskell/hunit-1.6:=[profile?] <dev-haskell/hunit-1.7:=[profile?]
22         >=dev-haskell/quickcheck-2.13.1:=[profile?]
23         >=dev-haskell/quickcheck-io-0.2.0:=[profile?]
24         dev-haskell/random:=[profile?]
25         dev-haskell/setenv:=[profile?]
26         >=dev-haskell/stm-2.2:=[profile?]
27         dev-haskell/tf-random:=[profile?]
28         >=dev-lang/ghc-8.4.3:=
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-2.2.0.1
32         test? (
33                 dev-haskell/base-orphans
34                 ~dev-haskell/hspec-meta-2.10.5
35                 >=dev-haskell/quickcheck-2.14
36                 >=dev-haskell/silently-1.2.4
37                 dev-haskell/temporary
38         )
41 pkg_pretend() {
42         if use test; then
43                 ewarn "The \"test\" USE flag for this package creates cycles within the"
44                 ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
45                 ewarn "It is recommended to leave it disabled unless explicitly testing the package."
46         fi