app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / dev-haskell / quickcheck / quickcheck-2.14.3.ebuild
blob6af1c5d02f8fc167b7a0ef71b75c531343de033c
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 # ebuild generated by hackport 0.8.4.0.9999
7 #hackport: flags: +base4,-base3,-old-random,templatehaskell:template-haskell
9 CABAL_PN="QuickCheck"
11 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
12 inherit haskell-cabal
14 DESCRIPTION="Automatic testing of Haskell programs"
15 HOMEPAGE="https://github.com/nick8325/quickcheck"
17 LICENSE="BSD"
18 SLOT="0/${PV}"
19 KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
20 IUSE="+template-haskell"
22 RDEPEND=">=dev-haskell/random-1.2.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
23         >=dev-haskell/splitmix-0.1:=[profile?] <dev-haskell/splitmix-0.2:=[profile?]
24         >=dev-lang/ghc-8.8.1:=
26 DEPEND="${RDEPEND}
27         >=dev-haskell/cabal-3.0.0.0
30 src_configure() {
31         haskell-cabal_src_configure \
32                 --flag=-base3 \
33                 --flag=base4 \
34                 --flag=-old-random \
35                 $(cabal_flag template-haskell templatehaskell)