app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / dev-haskell / text-show / text-show-3.9.7.ebuild
blobce1951597b3a9d76410228631d064ec649776d04
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 # ebuild generated by hackport 0.7.1.1.9999
7 #hackport: flags: -developer,-integer-gmp
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
12 DESCRIPTION="Efficient conversion of values into Text"
13 HOMEPAGE="https://github.com/RyanGlScott/text-show"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
20 RDEPEND=">=dev-haskell/base-compat-batteries-0.11:=[profile?] <dev-haskell/base-compat-batteries-0.13:=[profile?]
21         >=dev-haskell/bifunctors-5.1:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
22         dev-haskell/bytestring-builder:=[profile?]
23         >=dev-haskell/generic-deriving-1.14.1:=[profile?] <dev-haskell/generic-deriving-2:=[profile?]
24         >=dev-haskell/th-abstraction-0.4:=[profile?] <dev-haskell/th-abstraction-0.5:=[profile?]
25         >=dev-haskell/th-lift-0.7.6:=[profile?] <dev-haskell/th-lift-1:=[profile?]
26         >=dev-haskell/transformers-compat-0.5:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
27         >=dev-lang/ghc-8.4.3:=
29 DEPEND="${RDEPEND}
30         >=dev-haskell/cabal-2.2.0.1
31         test? ( >=dev-haskell/base-orphans-0.8.5 <dev-haskell/base-orphans-0.9
32                 >=dev-haskell/deriving-compat-0.6 <dev-haskell/deriving-compat-1
33                 >=dev-haskell/hspec-2 <dev-haskell/hspec-3
34                 >=dev-haskell/quickcheck-2.12 <dev-haskell/quickcheck-2.15
35                 >=dev-haskell/quickcheck-instances-0.3.26 <dev-haskell/quickcheck-instances-0.4 )
38 src_configure() {
39         haskell-cabal_src_configure \
40                 --flag=-developer \
41                 --flag=-integer-gmp