app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / dev-haskell / yesod / yesod-1.6.2.1.ebuild
blobe0052e1cac93d97b8594fc90c4aea87b6b1551e8
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 # ebuild generated by hackport 0.8.2.0.9999
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
11 DESCRIPTION="Creation of type-safe, RESTful web applications"
12 HOMEPAGE="https://www.yesodweb.com/"
14 LICENSE="MIT"
15 SLOT="0/${PV}"
16 KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
18 RDEPEND="dev-haskell/aeson:=[profile?]
19         >=dev-haskell/conduit-1.3:=[profile?]
20         dev-haskell/data-default-class:=[profile?]
21         dev-haskell/fast-logger:=[profile?]
22         dev-haskell/file-embed:=[profile?]
23         dev-haskell/monad-logger:=[profile?]
24         dev-haskell/shakespeare:=[profile?]
25         dev-haskell/streaming-commons:=[profile?]
26         dev-haskell/text:=[profile?]
27         dev-haskell/unordered-containers:=[profile?]
28         >=dev-haskell/wai-1.3:=[profile?]
29         >=dev-haskell/wai-extra-1.3:=[profile?]
30         dev-haskell/wai-logger:=[profile?]
31         >=dev-haskell/warp-1.3:=[profile?]
32         >=dev-haskell/yaml-0.8.17:=[profile?]
33         >=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
34         >=dev-haskell/yesod-form-1.6:=[profile?] <dev-haskell/yesod-form-1.8:=[profile?]
35         >=dev-haskell/yesod-persistent-1.6:=[profile?] <dev-haskell/yesod-persistent-1.7:=[profile?]
36         >=dev-lang/ghc-8.8.1:=
38 DEPEND="${RDEPEND}
39         >=dev-haskell/cabal-3.0.0.0