1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit elisp-common toolchain-funcs
8 DESCRIPTION="Lisp-flavoured Erlang"
9 HOMEPAGE="http://lfe.github.io/"
11 if [[ "${PV}" == *9999* ]]; then
14 EGIT_REPO_URI="https://github.com/rvirding/${PN}.git"
16 SRC_URI="https://github.com/rvirding/${PN}/archive/refs/tags/${PV}.tar.gz
18 KEYWORDS="~amd64 ~x86"
21 RESTRICT="mirror test"
31 doc? ( virtual/pandoc )
34 SITEFILE="70${PN}-gentoo.el"
39 sed -i "s|cc |$(tc-getCC) ${CFLAGS} |g" ./Makefile \
40 || die "Failed to fix the makefile"
47 use emacs && emake emacs
51 dodir "/usr/$(get_libdir)/erlang/lib/lfe/ebin/"
52 cp -R ./ebin "${D}/usr/$(get_libdir)/erlang/lib/lfe/"
61 elisp-install lfe emacs/* \
62 || die "elisp-install failed"
63 elisp-site-file-install "${FILESDIR}/${SITEFILE}"
68 use emacs && elisp-site-regen
72 use emacs && elisp-site-regen