app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / dev-ml / dune-build-info / dune-build-info-3.16.1.ebuild
bloba3661b549fcb010052da344f6084915f68995caf
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit dune
8 DESCRIPTION="Embed locations informations inside executable and libraries"
9 HOMEPAGE="https://github.com/ocaml/dune"
10 SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
11 S="${WORKDIR}/dune-${PV}"
13 LICENSE="MIT"
14 SLOT="0/${PV}"
15 KEYWORDS="~amd64 ~ppc64 ~x86"
16 IUSE="+ocamlopt"
17 RESTRICT="test"
19 RDEPEND=">=dev-ml/dune-3.12"
20 DEPEND="${RDEPEND}"
22 src_configure() {
23         :
26 src_compile() {
27         dune-compile ${PN}