app-shells/bash-completion: add 2.16.0
[gentoo/gentoo.git] / dev-ml / zed / zed-3.2.2-r1.ebuild
blob8e32cbb4d079fdb7f691192403b667444cd1627a
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit dune
8 DESCRIPTION="Abstract engine for text edition in OCaml"
9 HOMEPAGE="https://github.com/ocaml-community/zed"
10 SRC_URI="https://github.com/ocaml-community/zed/archive/${PV}.tar.gz
11         -> ${P}.tar.gz"
13 LICENSE="BSD"
14 SLOT="0/${PV}"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="+ocamlopt test"
17 RESTRICT="!test? ( test )"
19 RDEPEND="
20         >=dev-ml/dune-3
21         dev-ml/react:=
22         dev-ml/result:=
23         dev-ml/uchar:=
24         dev-ml/uucp:=
25         dev-ml/uuseg:=
26         dev-ml/uutf:=
28 DEPEND="${RDEPEND}"
29 BDEPEND="test? (
30         dev-ml/alcotest