app-metrics/prometheus: add 3.1.0
[gentoo/gentoo.git] / dev-php / PEAR-Mail_Mime / PEAR-Mail_Mime-1.10.12.ebuild
blob056b154d975a4c7de997a2f57a337acdbe8777d4
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit php-pear-r2
8 DESCRIPTION="Create and manipulate mime messages with PHP"
10 LICENSE="BSD"
11 SLOT="0"
12 KEYWORDS="amd64 arm ~hppa ppc64 ~s390 sparc x86"
13 IUSE="test"
15 RESTRICT="!test? ( test )"
17 BDEPEND="test? ( dev-php/PEAR-PEAR )"
19 src_test() {
20         # Requires the "pear" executable from dev-php/PEAR-PEAR.
21         pear run-tests tests || die
23         # The command succeeds regardless of whether or not the test suite
24         # passed, but this file is only written when there was a failure.
25         [[ -f run-tests.log ]] && die "test suite failed"