profiles/features/musl: mask app-crypt/mit-krb5-appl
[gentoo/gentoo.git] / dev-ruby / net-scp / net-scp-4.0.0.ebuild
blob4ab4f1e3f33c1009ee54786efdbf49a98b6991f7
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 USE_RUBY="ruby31 ruby32 ruby33"
8 RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
10 RUBY_FAKEGEM_TASK_TEST=""
12 RUBY_FAKEGEM_GEMSPEC="net-scp.gemspec"
14 inherit ruby-fakegem
16 DESCRIPTION="A pure Ruby implementation of the SCP client protocol"
17 HOMEPAGE="https://github.com/net-ssh/net-scp"
18 SRC_URI="https://github.com/net-ssh/net-scp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
20 LICENSE="GPL-2"
21 SLOT="2"
22 KEYWORDS="amd64 ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
23 IUSE="test"
24 RESTRICT="!test? ( test )"
26 ruby_add_bdepend "
27         doc? ( dev-ruby/net-ssh:7 )
28         test? (
29                 <dev-ruby/mocha-2.2.0:2
30                 dev-ruby/test-unit
31         )"
33 ruby_add_rdepend "dev-ruby/net-ssh:7"
35 all_ruby_prepare() {
36         sed -e "s:_relative ': './:" \
37                 -e 's/git ls-files -z/find -print0/' \
38                 -i ${RUBY_FAKEGEM_GEMSPEC} || die
40         sed -e '/mocha/ s/setup/test_unit/' \
41                 -i test/common.rb || die
44 each_ruby_test() {
45         ${RUBY} -Ilib:test test/test_all.rb || die